Skip navigation links
Unsupported Browser Detected – For best results, please update your browser.

Aviation Alerts and Advisories

Service Advisory 20126 Rev B: G5 Battery Pack

REVISION B:

Updated for the Ver. 3 Battery Pack

PRODUCTS AFFECTED:

All G5 products are affected.

ISSUE:

The 010-12493-00 G5 Battery Pack and the 010-12493-01 G5 Battery Pack Ver. 2 are now replaced by the 010-12493-02 G5 Battery Pack Ver. 3. The -02 has the same form, fit, and function as the -00 and the -01 battery pack.

The -02 battery pack does require G5 Software Version 6.80 or later. Not upgrading to G5 Software Version 6.80 (or later) will result in a battery fault message.

ACTION:

Make sure all G5 units with a 010-12493-02 battery pack have G5 Software Version 6.80 or later.

Service Advisory 20126 Rev B