Skip navigation links
Unsupported Browser Detected – For best results, please update your browser.

Aviation Alerts and Advisories

GWX 68 Software Version 2.20 for Non-GX000 Integrated Flight Deck Installations Only

PRODUCTS AFFECTED:

GWX 68 units with software version 2.12 (or earlier) and interfaced to a G500/G600, G500 TXi/G600 TXi, GTN 7XX, GMX 200, or other 3rd party flight display systems are affected.

CERTIFICATION APPROVAL:

TSO Authorization

COMPLIANCE:

Optional: This Service Bulletin may be incorporated at the owner’s discretion and is not warranty reimbursable.

PURPOSE:

GWX 68 software version 2.20 improves voltage monitoring and handling of aircraft power supply transient voltages. GWX 68 software version 2.20 is also the minimum GWX 68 software version needed for G500 TXi and G600 TXi installations.

ASDN 1840A