Skip navigation links

Aviation Alerts and Advisories

G5 Electronic Flight Instrument Software Update and GFC 500 (GMC 507 and GSA 28) Software Update

PRODUCTS AFFECTED:

G5 systems installed under G5 Part 23 AML STC SA01818WI are affected.

GFC 500 systems under GFC 500 Part 23 AML STC SA01866WI are affected.

CERTIFICATION AUTHORIZATION:

STC SA01818WI (G5) and STC SA01866WI (GFC 500)

COMPLIANCE:

Recommended.  This service bulletin is recommended for G5 systems installed per Part 23 AML STC SA01818WI and for GFC 500 systems installed per Part 23 AML STC SA01866WI.

PURPOSE:

G5 Software version 6.40 enables display of density altitude (DALT) for certified installations and includes updated GMC 507 and GSA 28 software versions.

GMC 507 Software version 2.90 includes more robust monitoring for a missing (broken) AP Disconnect wire during pre-flight test (PFT).

GSA 28 Software version 4.50 moves the altitude hold loop processing from the G5 to the GSA 28 to allow the pitch servo to fly to a target altitude. Additionally, it provides more robust monitoring of whether there are two servos with the same strap ID on the CAN network.

ASDN Service Bulletin 2007 Rev A